Open Side Menu Go to the Top
Can't connect to DB Can't connect to DB

02-26-2009 , 06:40 AM
I have been using PT3 for a while. I downloaded it while in the UK, I am now back in Australia with a different web connection and now it can't connect to the database.

Can anyone help?
02-26-2009 , 12:40 PM
Your PT3 database is actually located on your own computer in PostgreSQL.

Did you install PostgreSQL? Click Start --> Programs --> PostgreSQL --> Start Services to start the PostgreSQL service. If you don't see the "Start Services" link or the PostgreSQL folder then you don't have PostgreSQL installed and you will need to download and install PokerTracker 3 Build 4 with PostgreSQL from our download page.

If you have PostgreSQL installed, the default values are:
Server: localhost
Port: 5432
User: postgres
Password: dbpass

If this password does not work for you, you can disable password authentication by following the directions of this tutorial.
03-04-2009 , 04:38 AM
When I start client services it opens a DOS prompt that says the service is starting, but nothing happens?
03-04-2009 , 12:10 PM
Click Start --> Control Panel --> Administrative Tools --> Event Viewer, click on Application and if there are any Errors listed on the right hand side for postgres, double click them and tell me what they say that should shed some light on the issue.
03-05-2009 , 07:58 AM
There are errors, Event ID is always 0. The description is:

2009-02-15 12:07:14 GMT FATAL: could not create lock file "": Permission denied
03-05-2009 , 01:28 PM
Click Start, and then click My Computer. On the Tools menu, click Folder Options and click the View tab. In the Advanced Settings section, click to clear the Use simple file sharing (Recommended) check box. Click OK.

Then click Start --> Run type C:\Program Files\ and hit enter. Right click on PostgreSQL, click Properties. Go to the Security tab, click Add up top, then click Advanced, and Find Now. Find the postgres user at the bottom and click 'ok' twice. Then with the postgres user highlighted up top, check the Full Access checkbox on the bottom and click OK.

Then you should be able to start the PostgreSQL service properly.