Two Plus Two Publishing LLC
Two Plus Two Publishing LLC
 

Go Back   Two Plus Two Poker Forums > >

Notices

Commercial Software Discussion of commercial gambling-related / poker software & commercial graphics modifications

Reply
 
Thread Tools Display Modes
Old 04-20-2011, 08:55 AM   #2851
Drivo
enthusiast
 
Join Date: May 2008
Posts: 54
Re: StackAndTile - multi-site table manager

Hey Greg, quick question

I play on Ongame and have created a custom site for SaT. During play, i'm using three hotkeys, F,G and H (Respectively: Fold and stack, check/Call and Bet).

Check/Call and Bet/raise always work. The 'fold and stack' hotkey only works during normal play, when i have all three possibilities (fold, call/check and bet/raise) When somebody raises me all-in, i can always call with the hotkey, but i've got a problem with the fold and stack hotkey. When i press it during an all-in from villain, it doesn't fold, but only stacks my table.

Because the call button does work, i would say the buttons are in the same position as during normal play (when i've got three possibilities: Fold, call/check and bet/raise.)

NB. There is NO raise button visible during the allin from villain, so only two buttons appear. Does this probably has anything to do with it?

I've tested it with pokerstars this morning (hyper simple) and if i remember well i could fold and stack with no problems during all in situations.

Any ideas?

Edit:

The problem also appears when i set my hotkey to 'fold' instead of 'fold and stack'. Then it just does nothing. Besides the problem when only two buttons are visible, it also happens when three buttons are visible, but i only have to option to push, call or fold. In other words: when there is no possibility to make a normal raise because already 80% of my stack is in. Do you understand what i mean?

Last edited by Drivo; 04-20-2011 at 09:09 AM.
Drivo is offline   Reply With Quote
Old 04-20-2011, 09:51 AM   #2852
Drivo
enthusiast
 
Join Date: May 2008
Posts: 54
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by Drivo View Post
Hey Greg, quick question

I play on Ongame and have created a custom site for SaT. During play, i'm using three hotkeys, F,G and H (Respectively: Fold and stack, check/Call and Bet).

Check/Call and Bet/raise always work. The 'fold and stack' hotkey only works during normal play, when i have all three possibilities (fold, call/check and bet/raise) When somebody raises me all-in, i can always call with the hotkey, but i've got a problem with the fold and stack hotkey. When i press it during an all-in from villain, it doesn't fold, but only stacks my table.

Because the call button does work, i would say the buttons are in the same position as during normal play (when i've got three possibilities: Fold, call/check and bet/raise.)

NB. There is NO raise button visible during the allin from villain, so only two buttons appear. Does this probably has anything to do with it?

I've tested it with pokerstars this morning (hyper simple) and if i remember well i could fold and stack with no problems during all in situations.

Any ideas?

Edit:

The problem also appears when i set my hotkey to 'fold' instead of 'fold and stack'. Then it just does nothing. Besides the problem when only two buttons are visible, it also happens when three buttons are visible, but i only have to option to push, call or fold. In other words: when there is no possibility to make a normal raise because already 80% of my stack is in. Do you understand what i mean?

Ok, to answer my own question. The fold, check/call and bet/raise buttons of Ongame (Goalwin in this case) are located LOWER in the window when you can only call or fold, because there is no bet slider at the bottom of the page. In other words, the buttons are located HIGHER in the window when the bet slider is present. What i did to solve this, is creating a new custom site and the following.

When asked to click on the fold button, i clicked very low on the button (because in this case, the button is slightly higher then in the case i described above). When asked for the region of the button, i selected the lower third of the button, because that was approximately the overlap part.

I did the same for the other two buttons et voilà, problem solved. Don't know if anybody else has (had) this problem, but this is definitely the only solution.
Drivo is offline   Reply With Quote
Old 04-20-2011, 10:29 AM   #2853
rh300487
old hand
 
Join Date: Jun 2010
Posts: 1,864
Re: StackAndTile - multi-site table manager

ok greg, about to try it now..

Maybe you can add CustomSiteInstaller.exe as a shortcut in the file menu.. Would be very comfortable instead of browsing though my directories.

Going to try now.. will let you know.
rh300487 is offline   Reply With Quote
Old 04-20-2011, 10:39 AM   #2854
rh300487
old hand
 
Join Date: Jun 2010
Posts: 1,864
Re: StackAndTile - multi-site table manager

just downloaded it and get the same error

ERROR. No action_button found for myIpoker


this is the code:

Code:
[settings]

standard_table_width=852
standard_table_height=643

buttons=fold,call,bet

action_button=fold

fold_button_x_coord=301
fold_button_y_coord=582
fold_button_region_topleft_x_coord=242
fold_button_region_topleft_y_coord=557
fold_button_region_bottomright_x_coord=364
fold_button_region_bottomright_y_coord=611

call_button_x_coord=426
call_button_y_coord=583
call_button_region_topleft_x_coord=364
call_button_region_topleft_y_coord=558
call_button_region_bottomright_x_coord=488
call_button_region_bottomright_y_coord=613

bet_button_x_coord=554
bet_button_y_coord=581
bet_button_region_topleft_x_coord=488
bet_button_region_topleft_y_coord=558
bet_button_region_bottomright_x_coord=612
bet_button_region_bottomright_y_coord=609

use_basic_click=0

table_class=PTIODEVICE

table_include_title_text=$
table_exclude_title_text=Nickname
rh300487 is offline   Reply With Quote
Old 04-20-2011, 11:40 AM   #2855
Stu_the_kid_Ungar
grinder
 
Join Date: Nov 2008
Posts: 423
Re: StackAndTile - multi-site table manager

Hey Greg

How are you doing on the tile mode front?

Best wishes
Stu_the_kid_Ungar is offline   Reply With Quote
Old 04-20-2011, 12:08 PM   #2856
greg nice
Carpal \'Tunnel
 
greg nice's Avatar
 
Join Date: Aug 2004
Posts: 9,472
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by Drivo View Post
Ok, to answer my own question. The fold, check/call and bet/raise buttons of Ongame (Goalwin in this case) are located LOWER in the window when you can only call or fold, because there is no bet slider at the bottom of the page. In other words, the buttons are located HIGHER in the window when the bet slider is present. What i did to solve this, is creating a new custom site and the following.

When asked to click on the fold button, i clicked very low on the button (because in this case, the button is slightly higher then in the case i described above). When asked for the region of the button, i selected the lower third of the button, because that was approximately the overlap part.

I did the same for the other two buttons et voilà, problem solved. Don't know if anybody else has (had) this problem, but this is definitely the only solution.
excellent job Drivo, i'm impressed with your troubleshooting your assumptions are correct. if the buttons move depending on different actions, then SaT doesn't know where to click. if the Fold button isnt visible certain times, then that will create problems with the hotkey and also for SaT determine if a table has action required. so keep an eye out for that case too

if you care to post your OnGame config, i'll host it on the site for others to use. i'm sure it will be very helpful


Quote:
Originally Posted by rh300487 View Post
Maybe you can add CustomSiteInstaller.exe as a shortcut in the file menu.. Would be very comfortable instead of browsing though my directories.
will do, ill change in next version, or maybe ill add a start menu shortcut



Quote:
Originally Posted by rh300487 View Post
just downloaded it and get the same error

ERROR. No action_button found for myIpoker
yeah, a few people reported this error, and i fixed it and re-uploaded a new v.1.99.19. maybe your browser cached the old version of the download, or when you installed it, you didnt overwrite the existing installation. if youre feeling risky, maybe try backing up all your configs and custom site configs, uninstalling and then installing a fresh copy.


Quote:
Originally Posted by Stu_the_kid_Ungar View Post
Hey Greg

How are you doing on the tile mode front?

Best wishes
hey Stu, its on the backburner for now. theres just so much to do to make this a commercial application, its staggering really. just setting up the website has taken a lot of time and i havent even written help files yet (but the forums are live!). then i have to integrate a payment solution, all the while supporting users and fixing bugs.

i present this quote:
Quote:
Quote:
Originally Posted by Hood View Post
Hehe yep, pretty much describes all of my projects started over a 10 year span, bar 2 or 3.

The last 20% will take 80% of total time, and it's all crappy mundane work, not the fun initial dev stuff. If you get a solid working demo in 1 week expect 2 months to ship it.

Most don't have that real desire to give it the big push.
greg nice is offline   Reply With Quote
Old 04-20-2011, 12:36 PM   #2857
Drivo
enthusiast
 
Join Date: May 2008
Posts: 54
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by greg nice View Post
if the Fold button isnt visible certain times, then that will create problems with the hotkey and also for SaT determine if a table has action required. so keep an eye out for that case too
You're right on this, the table won't return to the grid on preflop action. Still working on that, might have to select the compete region where both fold buttons appear. Will posts results in a few minutes.
Drivo is offline   Reply With Quote
Old 04-20-2011, 12:37 PM   #2858
rh300487
old hand
 
Join Date: Jun 2010
Posts: 1,864
Re: StackAndTile - multi-site table manager

no still doesnt work.......
rh300487 is offline   Reply With Quote
Old 04-20-2011, 12:39 PM   #2859
rh300487
old hand
 
Join Date: Jun 2010
Posts: 1,864
Re: StackAndTile - multi-site table manager

to add, im running version 1.99.19
rh300487 is offline   Reply With Quote
Old 04-20-2011, 12:52 PM   #2860
Drivo
enthusiast
 
Join Date: May 2008
Posts: 54
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by Drivo View Post
You're right on this, the table won't return to the grid on preflop action. Still working on that, might have to select the compete region where both fold buttons appear. Will posts results in a few minutes.
Bam. Solved. Just selected the compete region of BOTH fold, check/call and bet/raise buttons, so they are recognized when action is required. The clicks were positioned near the center-bottom of the buttons when the slider is present, in order to be able to click somewhere at the top of the button when the slider isn't present.

The file is uploaded with yousendit, so it is only available for some days. If you want to host it on your site, that's fine by me of course.

Here's the file

I wonder if it is usefull, because others use different table sizes. Maybe i'm wrong.
Drivo is offline   Reply With Quote
Old 04-20-2011, 02:55 PM   #2861
Drivo
enthusiast
 
Join Date: May 2008
Posts: 54
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by Drivo View Post
Bam. Solved. Just selected the compete region of BOTH fold, check/call and bet/raise buttons, so they are recognized when action is required. The clicks were positioned near the center-bottom of the buttons when the slider is present, in order to be able to click somewhere at the top of the button when the slider isn't present.

The file is uploaded with yousendit, so it is only available for some days. If you want to host it on your site, that's fine by me of course.

Here's the file

I wonder if it is usefull, because others use different table sizes. Maybe i'm wrong.
Hey Greg, problem only party solved, table is not recognized when the slider isn't present, so when the call and fold buttons are slightly lower. I'm quite sure i selected the area where both buttons appear. Any ideas?

Drivo is offline   Reply With Quote
Old 04-20-2011, 03:56 PM   #2862
greg nice
Carpal \'Tunnel
 
greg nice's Avatar
 
Join Date: Aug 2004
Posts: 9,472
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by Drivo View Post
Hey Greg, problem only party solved, table is not recognized when the slider isn't present, so when the call and fold buttons are slightly lower. I'm quite sure i selected the area where both buttons appear. Any ideas?

haha wow. what a pain in the ass. the button regions are not for action, they are for detecting mouse clicks within the region. the specific fold button click determines if the table needs action. so you are correct to try to click near the bottom where the click would emcompass both fold button locations.

there is something you can try though, but it might mess up your other sites. in your SaT config (File -> Current config) you can add this line under [settings]:

Code:
[settings]
...
color_variation=128
i dont know exactly what number to tell you. this setting determines the range of colors to determine if the fold button color matches. it looks like the fold button color in your image is blue, and the background is black. the default is 36, but you can try higher and higher numbers and see if it matches. the problem is, if you go too high, and it matches the black background as well, then it will think all tables need action
greg nice is offline   Reply With Quote
Old 04-20-2011, 03:57 PM   #2863
greg nice
Carpal \'Tunnel
 
greg nice's Avatar
 
Join Date: Aug 2004
Posts: 9,472
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by rh300487 View Post
no still doesnt work.......
ok, ill check into it again
greg nice is offline   Reply With Quote
Old 04-20-2011, 04:42 PM   #2864
evasive
journeyman
 
Join Date: Sep 2005
Posts: 259
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by rh300487 View Post
to add, im running version 1.99.19
Have you altered the size of the chatbox at all ? - it moves the buttons
evasive is offline   Reply With Quote
Old 04-20-2011, 06:55 PM   #2865
greg nice
Carpal \'Tunnel
 
greg nice's Avatar
 
Join Date: Aug 2004
Posts: 9,472
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by evasive View Post
Have you altered the size of the chatbox at all ? - it moves the buttons
are you talking to rh3 or Drivo?
greg nice is offline   Reply With Quote
Old 04-20-2011, 10:24 PM   #2866
rh300487
old hand
 
Join Date: Jun 2010
Posts: 1,864
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by evasive View Post
Have you altered the size of the chatbox at all ? - it moves the buttons
Yes, the chatbox is small, but thats also how i configured it. The location of the buttons should be the same as the way i configured them. (hope that sounds clear..)
rh300487 is offline   Reply With Quote
Old 04-21-2011, 04:37 AM   #2867
Drivo
enthusiast
 
Join Date: May 2008
Posts: 54
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by greg nice View Post
haha wow. what a pain in the ass. the button regions are not for action, they are for detecting mouse clicks within the region. the specific fold button click determines if the table needs action. so you are correct to try to click near the bottom where the click would emcompass both fold button locations.

there is something you can try though, but it might mess up your other sites. in your SaT config (File -> Current config) you can add this line under [settings]:

Code:
[settings]
...
color_variation=128
i dont know exactly what number to tell you. this setting determines the range of colors to determine if the fold button color matches. it looks like the fold button color in your image is blue, and the background is black. the default is 36, but you can try higher and higher numbers and see if it matches. the problem is, if you go too high, and it matches the black background as well, then it will think all tables need action
Greg, i tried to determine where the colors match the most (between high and low button) and it seems i got it. At the right and left side there is a shadow which goes from up to down. i clicked on the bottom right part of all three buttons and it looks like it detects 'both' the tables now Yay

Have to do some testing this afternoon, but i'm quite sure it will do it's job now. To be sure i've added some color variation. When i alter the ini file for color variation, do i have to re-add the site? Or does it update at a SaT restart?

Thank you for your extensive reply.
Drivo is offline   Reply With Quote
Old 04-21-2011, 07:39 AM   #2868
Drivo
enthusiast
 
Join Date: May 2008
Posts: 54
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by Drivo View Post
Greg, i tried to determine where the colors match the most (between high and low button) and it seems i got it. At the right and left side there is a shadow which goes from up to down. i clicked on the bottom right part of all three buttons and it looks like it detects 'both' the tables now Yay

Have to do some testing this afternoon, but i'm quite sure it will do it's job now. To be sure i've added some color variation. When i alter the ini file for color variation, do i have to re-add the site? Or does it update at a SaT restart?

Thank you for your extensive reply.
Ok, to quote myself. Fixed it. Also discovered that the ini file is updated at restart of SaT, no need to remove and add site.

The file is located HERE , fine if you host it.

Have a nice day
Drivo is offline   Reply With Quote
Old 04-21-2011, 01:37 PM   #2869
greg nice
Carpal \'Tunnel
 
greg nice's Avatar
 
Join Date: Aug 2004
Posts: 9,472
Re: StackAndTile - multi-site table manager

yes the ini is loaded upon start. no need to reinclude sites. however, i noticed that you put the color_variation inside the goalwin3.ini. i was trying to tell you that that setting should go inside the actual SaT config.ini, otherwise it wont have any effect. but if its working, dont mess with it. next version ill see if i can implement it so that the color_variation will be read from the custom site config where you have it anyway.
greg nice is offline   Reply With Quote
Old 04-21-2011, 03:04 PM   #2870
Drivo
enthusiast
 
Join Date: May 2008
Posts: 54
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by greg nice View Post
yes the ini is loaded upon start. no need to reinclude sites. however, i noticed that you put the color_variation inside the goalwin3.ini. i was trying to tell you that that setting should go inside the actual SaT config.ini, otherwise it wont have any effect. but if its working, dont mess with it. next version ill see if i can implement it so that the color_variation will be read from the custom site config where you have it anyway.
hmm, of course. How stupid. You warned me about the fact that the color variation could mess up ALL my sites. So, no need for color variation i guess
Drivo is offline   Reply With Quote
Old 04-21-2011, 04:05 PM   #2871
nostrakhan
journeyman
 
nostrakhan's Avatar
 
Join Date: Oct 2007
Posts: 318
Re: StackAndTile - multi-site table manager

How can I get this working with a site on the Merge network (RPM)? I read something about custom site addition but I can't find it in the program.
nostrakhan is offline   Reply With Quote
Old 04-21-2011, 05:00 PM   #2872
nostrakhan
journeyman
 
nostrakhan's Avatar
 
Join Date: Oct 2007
Posts: 318
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by nostrakhan View Post
How can I get this working with a site on the Merge network (RPM)? I read something about custom site addition but I can't find it in the program.
Nevermind, I found the customsitecreator.exe in the program folder. It seems to be working perfectly. Thanks for the great program!
nostrakhan is offline   Reply With Quote
Old 04-22-2011, 12:04 AM   #2873
greg nice
Carpal \'Tunnel
 
greg nice's Avatar
 
Join Date: Aug 2004
Posts: 9,472
Re: StackAndTile - multi-site table manager

Quote:
Originally Posted by nostrakhan View Post
Nevermind, I found the customsitecreator.exe in the program folder. It seems to be working perfectly. Thanks for the great program!
next version i'm going to put a new option in the Sites dropdown for "Other.." which will open up the CustomSiteCreator


Quote:
Originally Posted by pokerash View Post
Just FYI, I tried setting the old tables to 0 and grid expecting nothing to happen but the tables just keep rotating round until they hit the last slot. So I have set it to a very high number instead
hrm, if you set Duration=0 then every table will get detected as 'old' immediately. to disable it, you should set Old Tables Slot=0
greg nice is offline   Reply With Quote
Old 04-24-2011, 05:47 AM   #2874
SantaCruz
Pooh-Bah
 
Join Date: Dec 2010
Posts: 4,164
Re: StackAndTile - multi-site table manager

Everthing I've read says that Pokerstars will continue to offer play money games to US members.
SantaCruz is offline   Reply With Quote
Old 04-24-2011, 12:42 PM   #2875
rh300487
old hand
 
Join Date: Jun 2010
Posts: 1,864
Re: StackAndTile - multi-site table manager

any news on the iPoker issue?
rh300487 is offline   Reply With Quote

Reply
      

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Forum Jump


All times are GMT -4. The time now is 10:55 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2008-2017, Two Plus Two Interactive
 
 
Poker Players - Streaming Live Online